Low disk space: Windows will stop working correctly – level 100

Here a little tip from experience:  If a server starts acting funny, check the disk space.  If you are almost out of space, Windows won’t be able to function correctly.  Symptoms of this may be slow time to remote desktop in, or a host of other “weird” things that you are unable to explain.  In fact, some .Net applications may fail to run with a “Can’t find XXX assembly” error.  The assembly is where it’s supposed to be, but if .Net can’t allocate space for the shadow copy, then it can’t start the application (yes, I’ve had this happen to me).

The more free space the better, and if the server is approaching the megabytes of free space on the main drive, ask your IT people to correct it before trying to do anything with that server.  You’ll waste your time if you really need the server for something, and it won’t cooporate.  You can beg and plead as much as you want, but a server without free disk space won’t care that you have a major deadline rapidly approaching.

2 comments

  1. Don’t knock this simple tip. I once had our outsourced service provide call me with all kinds of issues the server was having running a SharePoint server. Since I didn’t have access to the server, I came up with a number of diagnosises around what might be the problem. When I did finally get access, I did a dir on the c: drive and immiately found it had about 100k remaining.

    If you have monitoring software to monitor disk space, it might not work because it need space to swap out and run the event to send you the notification so check the simple things like this first!

  2. venkatesh

    I have a website (ASP.NET 2.0+C#+SQL Server 2000) published on the server. The server’s disk space runs out and so the website is no longer viewable to the user. I would like to provide a custom message to the user, if the server space is low.

    How to provide the customized message to the user, incase the disk space on the primary drive( c:) runs out?

    Please help.

Comments are closed.